This package has been deprecated

Author message:

Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.

wttj-config-front

2.4.0 • Public • Published

wttj-config-front

Install

yarn add --dev wttj-config-front

Eslint

// .eslintrc.js
module.exports = {
  extends: './node_modules/wttj-config-front/lib/eslint',
  // or if you want typescript configuration
  // extends: './node_modules/wttj-config-front/lib/eslint/eslintrc-typescript',
  // or if you want cypress configuration
  // extends: './node_modules/wttj-config-front/lib/eslint/eslintrc-cypress',
}

Prettier

// prettier.config.js
module.exports = require('wttj-config-front/lib/prettier')

Stylelint

// stylelint.config.js
module.exports = {
  extends: './node_modules/wttj-config-front/lib/stylelint',
}

Tsconfig

// tsconfig.json
{
  "extends": "wttj-config-front/lib/tsconfig/tsconfig.json",
  "compilerOptions": {
    "baseUrl": "src"
  },
  "include": ["src"]
}

Scripts

// package.json
{
  "scripts": {
    // ...
    "lint": "yarn lint:js && yarn lint:css && yarn lint:ts",
    "lint:js": "eslint src --max-warnings 0",
    "lint:css": "stylelint 'src/**/styles.ts' --allow-empty-input",
    "lint:ts": "tsc --noEmit"
  }
},

VSCode

Install eslint and prettier extensions

// your settings.json
{
  "editor.formatOnSave": true,
  "editor.codeActionsOnSave": {
    "source.fixAll.eslint": true
  },
  "editor.defaultFormatter": "esbenp.prettier-vscode"
}

Package Sidebar

Install

npm i wttj-config-front

Weekly Downloads

4

Version

2.4.0

License

ISC

Unpacked Size

20.3 kB

Total Files

14

Last publish

Collaborators

  • anucreative
  • calvein
  • guillaume.rousseau.wttj
  • mesniltheo
  • mleralec
  • pxceccaldi