npm

Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

wrap-ansi

5.0.0 • Public • Published

wrap-ansi Build Status Coverage Status

Wordwrap a string with ANSI escape codes

Install

$ npm install wrap-ansi

Usage

const chalk = require('chalk');
const wrapAnsi = require('wrap-ansi');
 
const input = 'The quick brown ' + chalk.red('fox jumped over ') +
    'the lazy ' + chalk.green('dog and then ran away with the unicorn.');
 
console.log(wrapAnsi(input, 20));

API

wrapAnsi(input, columns, [options])

Wrap words to the specified column width.

input

Type: string

String with ANSI escape codes. Like one styled by chalk.

columns

Type: number

Number of columns to wrap the text to.

options

Type: Object

hard

Type: boolean
Default: false

By default the wrap is soft, meaning long words may extend past the column width. Setting this to true will make it hard wrap at the column width.

wordWrap

Type: boolean
Default: true

By default, an attempt is made to split words at spaces, ensuring that they don't extend past the configured columns. If wordWrap is false, each column will instead be completely filled splitting words as necessary.

trim

Type: boolean
Default: true

Whitespace on all lines is removed by default. Set this option to false if you don't want to trim.

Related

  • slice-ansi - Slice a string with ANSI escape codes
  • cli-truncate - Truncate a string to a specific width in the terminal
  • chalk - Terminal string styling done right
  • jsesc - Generate ASCII-only output from Unicode strings. Useful for creating test fixtures.

Maintainers

License

MIT

install

npm i wrap-ansi

Downloadsweekly downloads

9,016,148

version

5.0.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
Report a vulnerability