node package manager

vim-plugger

vim-plugger

A simplistic vim plugins downloader that presumes that you use pathogen. It's easier to use than git submodules and works faster than vundle (but doesn't have any of their features).

Usage

Create a bundle file:

var githubRefs = [
  'mileszs/ack.vim',
  'Lokaltog/vim-powerline',
  'chriskempson/base16-vim',
  'ap/vim-css-color',
  'tpope/vim-fugitive',
  'digitaltoad/vim-jade',
  'airblade/vim-gitgutter'
]
 
require('vim-plugger')(githubRefs, { cleanup: true });

Run it with node

node bundle.js