validatees
TypeScript icon, indicating that this package has built-in type declarations

1.2.3 • Public • Published

validatees

Bundle size  Downloads  License  Version  GitHub Repo stars  GitHub issues

Validation package for ES6+, TypeScript and JavaScript(CommonJS and Module) ready.

Features

  • 🚀Easy to use: Easy to install in your project.
  • ES6+ && TS: TypeScript and ES6+ support(JS).
  • 🐭Small footprint: With less then 20kb, you won't even notice.
  • 📦No dependencies: You don't depend on anything else.

Getting Started

Installation

To use this package, install using npm, yarn or pnpm📥:

# npm
npm install validatees
# yarn
yarn add validatees
# pnpm
pnpm install validatees

Usage

// ES6+ JavaScript CommonsJs
const validatees = require("validatees");
// TypeScript || ES6+ JavaScript module
import validatees from "validatees";

Documentation

For more information, please visit the documentation.

Contributing

Found a bug🦟? or want to suggest a new feature🆕? or just want to help🆘? Feel free to open an issue or a pull request.

Contributions are always welcome!🎉

  • Fork the project here.
  • Create a new branch like this: git checkout -b feature/featureName.
  • Commit your changes to your branch: git commit -m 'Create AwesomeFeature'⚙️.
  • Push your branch: git push origin feature/featureName.
  • Open a pull request on the dev branch here🔃.

📒Note: Make sure to add tests for your changes .

Package Sidebar

Install

npm i validatees

Weekly Downloads

217

Version

1.2.3

License

MIT

Unpacked Size

55.9 kB

Total Files

61

Last publish

Collaborators

  • m10rten