Nervously Practice Multithreading

    unexpected-date

    2.0.0 • Public • Published

    Unexpected-date

    NPM version Build Status Coverage Status Dependency Status

    Support for useful date/time assertions for Unexpected.js

    Table of Contents

    Why

    Use this module if you are looking for

    • Assertions on native Date objects
    • Dependency free light-weight module

    Installation

    You will need unexpected@10.32.0 or above to use this module.

    Node.js

    $ npm install --save-dev unexpected-date
    $ yarn add --dev unexpected-date
    
    var expect = require("unexpected").clone();
    expect.use(require("unexpected-date"));

    Documentation

    Checkout documentation site here

    Assertions Available

    • to be after
    • to be before
    • to be [inclusively] between
    • to be close to
    • to be same or after
    • to be same or before
    • to equal date
    • to equal time

    Notes

    This module is inspired from unexpected-moment assertions.

      This feature is exclusive to Teams

      Illustration of wombats

      The package file explorer is only available for Teams at the moment.

      We may support exploring this package in the future. Check back soon.

      Install

      npm i unexpected-date

      DownloadsWeekly Downloads

      43

      Version

      2.0.0

      License

      MIT

      Unpacked Size

      24.1 kB

      Total Files

      15

      Last publish

      Collaborators

      • avatar