Necessitates Proper Modularity

    tsparticles-updater-gradient
    TypeScript icon, indicating that this package has built-in type declarations

    2.3.2 • Public • Published

    banner

    tsParticles Gradient Updater

    jsDelivr npmjs npmjs GitHub Sponsors

    tsParticles updater plugin for gradient animations.

    How to use it

    CDN / Vanilla JS / jQuery

    The CDN/Vanilla version JS has one required file in vanilla configuration:

    Including the tsparticles.updater.gradient.min.js file will export the function to load the updater plugin:

    loadGradientUpdater
    

    Usage

    Once the scripts are loaded you can set up tsParticles and the updater plugin like this:

    loadGradientUpdater(tsParticles);
    
    tsParticles.load("tsparticles", {
      /* options */
    });

    ESM / CommonJS

    This package is compatible also with ES or CommonJS modules, firstly this needs to be installed, like this:

    $ npm install tsparticles-updater-gradient

    or

    $ yarn add tsparticles-updater-gradient

    Then you need to import it in the app, like this:

    const { tsParticles } = require("tsparticles-engine");
    const { loadGradientUpdater } = require("tsparticles-updater-gradient");
    
    loadGradientUpdater(tsParticles);

    or

    import { tsParticles } from "tsparticles-engine";
    import { loadGradientUpdater } from "tsparticles-updater-gradient";
    
    loadGradientUpdater(tsParticles);

    Install

    npm i tsparticles-updater-gradient

    DownloadsWeekly Downloads

    257

    Version

    2.3.2

    License

    MIT

    Unpacked Size

    382 kB

    Total Files

    62

    Last publish

    Collaborators

    • ar3s
    • matteobruni