Have ideas to improve npm?Join in the discussion! »

    tennu-dbcore

    3.0.0 • Public • Published

    tennu-dbcore

    A plugin for the tennu irc framework.

    tennu-dbcore uses knex on its backend. This means that if you wish to change from the default Sqlite3 DB you will have to follow their documentation and update the configuration below. I have provided a couple of examples.

    Upgrade Information

    Version 2 moved all migrations off to their own plugins. This way upgrading a plugin wont require also upgrading dbcore.

    Because they use their own migration tables now, they will try and run migrations twice.

    Back up all your data before upgrading and be prepared to do imports/exports.

    Installation

    You might have to install your database provider at the plugin level. IE: run npm install sqlite3 inside your-bot/npm_modules/tennu-dbcore/.

    The reason for this is I do not want to impose sqlite3 or/and mysql2 as a dependency on anyone. But one is required by knex.

    Configuration

    Add this to your tennu configuration (be sure to strip comments):

    sqlite3

    // Make sure to `npm install sqlite3`.
    "database": {
        "client": "sqlite3",
        "connection": {
          "filename": "./tennu.sqlite"
        }
    }

    mysql2

    // Mke sure to `npm install mysql2`.
    "database": {
        "client": "mysql2",
        "connection": {
            "host": "localhost",
            "user": "tennu-bot",
            "password": "password",
            // make sure this db actually exists, and that your user has access to it
            "database": "tennu"
        }
      }

    Plugins that require dbcore

    Installing Into Tennu

    See Downloadable Plugins here.

    Keywords

    none

    Install

    npm i tennu-dbcore

    DownloadsWeekly Downloads

    0

    Version

    3.0.0

    License

    ISC

    Last publish

    Collaborators

    • avatar