node package manager

sylphy

Sylphy

Studio 777 NPM version Dependency Status

NPM info

Sylphy is an advanced, efficient and highly customisable framework for Discord command bots written in Node.js

Getting Started

Requirements

  • Node.js 8.0.0+

As the bot framework extends the Eris client, please refer to the docs here.

The full Sylphy documentation can be found here.

Usage

$ npm install --save sylphy

Example

const Bot = require('sylphy')
 
const client = new Bot({
  token: 'your token here',
  modules: 'path/to/modules',
  // Eris client options here 
})
 
client.register('commands', 'path/to/commands')
 
client.run()

Documentation

To view the API, please visit the wiki.

License

Copyright (C) 2017 Pyraxo

This program is free software: you can redistribute it and/or modify it under the terms of the GNU Affero General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Affero General Public License for more details.