Nautilus: Pelagic Mollusc

    supports-ansi

    1.0.6 • Public • Published

    supports-ansi

    npm version

    Detect whether a terminal supports ANSI escape sequences

    Installation

    npm install --save supports-ansi

    Usage

    const supportsAnsi = require('supports-ansi');
     
    // on ANSI/VT100 compatible terminal
    console.log(supportsAnsi);
    // => true
     
    // on CMD/PowerShell (before Windows 10 v.1607)
    console.log(supportsAnsi);
    // => false

    Note

    Cygwin is not supported.

    License

    MIT

    Install

    npm i supports-ansi

    DownloadsWeekly Downloads

    3

    Version

    1.0.6

    License

    MIT

    Unpacked Size

    4.48 kB

    Total Files

    4

    Last publish

    Collaborators

    • dearke