spdx-correct
DefinitelyTyped icon, indicating that this package has TypeScript declarations provided by the separate @types/spdx-correct package

3.2.0 • Public • Published

Usage

var correct = require('spdx-correct')
var assert = require('assert')

assert.strictEqual(correct('mit'), 'MIT')

assert.strictEqual(correct('Apache 2'), 'Apache-2.0')

assert(correct('No idea what license') === null)

// disable upgrade option
assert(correct('GPL-3.0'), 'GPL-3.0-or-later')
assert(correct('GPL-3.0', { upgrade: false }), 'GPL-3.0')

Contributors

spdx-correct has benefited from the work of several contributors. See the GitHub repository for more information.

Package Sidebar

Install

npm i spdx-correct

Weekly Downloads

24,619,722

Version

3.2.0

License

Apache-2.0

Unpacked Size

23.4 kB

Total Files

4

Last publish

Collaborators

  • kemitchell
  • taleinat