semver-stable

semver-stable

semver-stable

Manage stable semver versions

$ npm install semver-stable --save
var stable = require('semver-stable');
stable.is('1.2.3');        // -> true 
stable.is('1.2.3-stable'); // -> false 
stable.is('1.2.3-alpha');  // -> false 

Returns Boolean whether the version is stable.

  • versions Array.<semver>
  • range String semver range
stable.maxSatisfying([
  '1.3.3',      // not match the range 
  '1.2.3-beta', // not a stable version 
  '1.2.2',      // that's it 
  '1.2.1',      // much older 
  '1.1.2'
], '~1.2.0');
// -> 1.2.2 

Returns String the latest stable version matches the range.

Returns String the max stable version.

MIT