sass-lint-webpack

    1.0.4 • Public • Published

    Sass-lint Webpack Plugin

    Sass-lint plugin for Webpack 4+

    Requirements

    Installation

    Yarn

    yarn add -D sass-lint sass-lint-webpack

    NPM

    npm install -D sass-lint sass-lint-webpack

    Usage

    Add following lines to your Webpack config file (eg. webpack.config.js).

    const SassLintPlugin = require('sass-lint-webpack')
    
    module.export = {
      // ...
      plugins: [
        // ...
        new SassLintPlugin(),
      ],
    }

    Options

    Normally the .sass-lint.yml file is all you need. It is also possible to manually pass options to sass-lint.

    • files - a glob pattern or single file path as a lint target
    • options - user specified rules/options passed in
    • configPath - path to a config file

    Sponsors

    License

    Copyright (c) 2022 Jianqiu Xiao swordray@gmail.com under the MIT License.

    Install

    npm i sass-lint-webpack

    DownloadsWeekly Downloads

    2,555

    Version

    1.0.4

    License

    MIT

    Unpacked Size

    5.3 kB

    Total Files

    7

    Last publish

    Collaborators

    • swordray