Noisy Pterodactyl Melodies

    sass-bem-next

    3.1.1 • Public • Published

    Version Version

    sass-bem-next

    Changes

    • Use dart-sass instead of node-sass
    • Use sass builtin modules instead of global functions
    • Fixed @mixin parse warning
    • Fixed @function splice recursive error

    Install

    npm i sass-bem-next --save-dev

    Vue CLI

    // vue.config.js
    module.exports = {
      css: {
        loaderOptions: {
          scss: {
            additionalData: `@import "sass-bem-next";`
          }
        }
      }
    }

    Vite

    // vite.config.ts
    import { defineConfig } from 'vite'
    
    export default defineConfig({
      css: {
        preprocessorOptions: {
          scss: {
            additionalData: `@import "sass-bem-next";`
          }
        }
      }
    })

    Usage

    sass-bem v2.6.5

    License

    The sass-bem-next package is also open-sourced software licensed under the MIT license.

    Install

    npm i sass-bem-next

    DownloadsWeekly Downloads

    17

    Version

    3.1.1

    License

    MIT

    Unpacked Size

    98 kB

    Total Files

    60

    Last publish

    Collaborators

    • savoygu