Miss any of our Open RFC calls?Watch the recordings here! »

runescape-api

1.0.6 • Public • Published

RuneScape API

Build Status Dependency Status

Introduction

runescape-api is an open-source wrapper, written in Node.js, that allows interaction with the various APIs available for the popular MMORPG RuneScape.

Installation

npm install runescape-api --save

Usage

The implementation offers functionality to interact with the following:

The example below explains how to gain access to the runescape-api library and fetch a beasts information.

var rsapi = require('runescape-api');
 
rsapi.rs.bestiary.beast(49).then(function(beast) {
    console.log(JSON.stringify(beast, null, 2));
}).catch(console.error);

Outputs:

{
  "animations": {
    "death": 17347,
    "attack": 17348
  },
  "slayercat": "Hellhounds",
  "xp": "344.4",
  "size": 2,
  "lifepoints": 3300,
  "weakness": "Slashing",
  "id": 49,
  "poisonous": false,
  "magic": 1,
  "attackable": true,
  "level": 92,
  "defence": 66,
  "description": "Hello, nice doggy...",
  "name": "Hellhound",
  "ranged": 1,
  "areas": [
    "Ardougne underground",
    "RuneScape Surface",
    "Forinthry Dungeon",
    "Taverley Dungeon",
    "Ancient cavern"
  ],
  "attack": 66,
  "aggressive": false,
  "members": false
}
 

More examples can be found in the examples folder.

License

runescape-api is under the MIT license, see the LICENSE file for the copyright information and licensing terms.

Keywords

none

Install

npm i [email protected]

Version

1.0.6

License

MIT

Last publish

Collaborators

  • avatar
  • avatar
  • avatar