retext-dutch
TypeScript icon, indicating that this package has built-in type declarations

5.0.0 • Public • Published

retext-dutch

Build Coverage Downloads Size Sponsors Backers Chat

retext plugin to add support for parsing Dutch natural language.

Contents

What is this?

This package is a unified (retext) plugin that defines how to take Dutch natural language as input and turn it into a syntax tree. When it’s used, natural language can be parsed and other retext plugins can be used after it.

See the monorepo readme for info on what the retext ecosystem is.

When should I use this?

This plugin adds support to unified for parsing Dutch. If the prose is not Dutch, use retext for any Latin-script text, or for English use unified itself with retext-english and retext-stringify.

If you just want the syntax tree, you can use parse-dutch directly.

Install

This package is ESM only. In Node.js (version 16+), install with npm:

npm install retext-dutch

In Deno with esm.sh:

import retextDutch from 'https://esm.sh/retext-dutch@5'

In browsers with esm.sh:

<script type="module">
  import retextDutch from 'https://esm.sh/retext-dutch@5?bundle'
</script>

Use

import retextDutch from 'retext-dutch'
import retextStringify from 'retext-stringify'
import {unified} from 'unified'
import {reporter} from 'vfile-reporter'

const file = await unified()
  .use(retextDutch)
  // Add your own plugins that work with Dutch here!
  .use(retextStringify)
  .process('Kunt U zich ’s morgens melden bij het afd. hoofd dhr. Venema')

console.log(String(file))
console.error(reporter(file))

Yields:

Kunt U zich ’s morgens melden bij het afd. hoofd dhr. Venema
no issues found

API

This package exports no identifiers. The default export is retextDutch.

unified().use(retextDutch)

Add support for parsing Dutch natural language.

Parameters

There are no parameters.

Returns

Nothing (undefined).

Syntax tree

The syntax tree used in retext is nlcst.

Types

This package is fully typed with TypeScript. It exports no additional types.

Compatibility

Projects maintained by the unified collective are compatible with maintained versions of Node.js.

When we cut a new major release, we drop support for unmaintained versions of Node. This means we try to keep the current release line, retext-dutch@^5, compatible with Node.js 16.

Contribute

See contributing.md in retextjs/.github for ways to get started. See support.md for ways to get help.

This project has a code of conduct. By interacting with this repository, organization, or community you agree to abide by its terms.

Sponsor

Support this effort and give back by sponsoring on OpenCollective!

Vercel

Motif

HashiCorp

GitBook

Gatsby

Netlify

Coinbase

ThemeIsle

Expo

Boost Note

Markdown Space

Holloway


You?

License

MIT © Titus Wormer

Package Sidebar

Install

npm i retext-dutch

Weekly Downloads

3

Version

5.0.0

License

MIT

Unpacked Size

12.1 kB

Total Files

6

Last publish

Collaborators

  • wooorm