npm

npm’s 2019 JavaScript ecosystem survey analysis is now available! Get your copy here »

require-object-coercible-x

1.4.3 • Public • Published

Travis status Dependency status devDependency status npm version

require-object-coercible-x

ES6-compliant shim for RequireObjectCoercible.

See: 7.2.1 RequireObjectCoercible ( argument )
Version: 1.4.3
Author: Xotic750 Xotic750@gmail.com
License: MIT
Copyright: Xotic750

module.exports(value)string

The abstract operation RequireObjectCoercible throws an error if argument is a value that cannot be converted to an Object using ToObject.

Kind: Exported function
Returns: string - The value.
Throws:

  • TypeError If value is a null or undefined.
Param Type Description
value * The value to check.

Example

var RequireObjectCoercible = require('require-object-coercible-x');
 
RequireObjectCoercible(); // TypeError
RequireObjectCoercible(null); // TypeError
RequireObjectCoercible('abc'); // 'abc'
RequireObjectCoercible(true); // true
RequireObjectCoercible(Symbol('foo')); // Symbol('foo')

install

npm i require-object-coercible-x

Downloadsweekly downloads

18,073

version

1.4.3

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability