redditapi

    1.0.1 • Public • Published

    Reddit

    A simple to use module for interacting with the Reddit API.

    Install

    $ npm install redditapi
    

    How to

    // require the package
    const reddit = require('redditapi');
    reddit('AskReddit', 13, 'hot').then(data => console.log(data));
    • sub reddit is required and must be a string.
    • amount is required and must be a string.
    • topic is new by default. Possible topics are hot, new, rising, controversial, top.

    Methods

    Post.minified(); // returns the data without null values

    Keywords

    Install

    npm i redditapi

    DownloadsWeekly Downloads

    4

    Version

    1.0.1

    License

    ISC

    Last publish

    Collaborators

    • jake-ruston