Naively Programmable Module

    razzle-plugin-modify-eslint-loader-config

    1.0.0 • Public • Published

    NPM version Build Status

    razzle-plugin-modify-eslint-loader-config

    This package contains a plugin which can be used to modify eslint loader config

    Usage in Razzle Projects

    yarn add razzle-plugin-modify-eslint-loader-config
    

    Using the plugin with the default options

    // razzle.config.js
    
    module.exports = {
      plugins: [
        'eslint',
        'modify-eslint-loader-config' // This plugin should always be after eslint plugin
      ],
    };

    With custom options:

    // razzle.config.js
    
    module.exports = {
      plugins: [
        'eslint',
        {
          // This plugin should always be after eslint plugin
          name: 'modify-eslint-loader-config',
          options: {
            fix: true,  // enable autofix
          },
        },
      ],
    };

    Options

    NB: By default this plugin sets emitWarning to true to force eslint errors to be shown as warnings (so compilation still succeeds).

    see https://github.com/webpack-contrib/eslint-loader#options

    License

    MIT © Thorgate

    Install

    npm i razzle-plugin-modify-eslint-loader-config

    DownloadsWeekly Downloads

    25

    Version

    1.0.0

    License

    MIT

    Unpacked Size

    4.49 kB

    Total Files

    4

    Last publish

    Collaborators

    • metsavaht