ranges-is-index-within
    TypeScript icon, indicating that this package has built-in type declarations

    3.0.2 • Public • Published

    ranges-is-index-within

    Checks if index is within any of the given string index ranges

    Install

    This package is ESM only: Node 12+ is needed to use it and it must be imported instead of required:

    npm i ranges-is-index-within

    If you need a legacy version which works with require, use version 2.1.0

    Quick Take

    import { strict as assert } from "assert";
    import { isIndexWithin } from "ranges-is-index-within";
    
    assert.equal(
      isIndexWithin(8, [
        [1, 2],
        [5, 10],
      ]),
      true
    );
    
    assert.equal(
      isIndexWithin(12, [
        [1, 2],
        [5, 10],
      ]),
      false
    );

    Documentation

    Please visit codsen.com for a full description of the API and examples.

    Contributing

    To report bugs or request features or assistance, raise an issue on GitHub.

    Licence

    MIT License

    Copyright (c) 2010-2021 Roy Revelt and other contributors

    ok codsen star

    Install

    npm i ranges-is-index-within

    DownloadsWeekly Downloads

    151

    Version

    3.0.2

    License

    MIT

    Unpacked Size

    16 kB

    Total Files

    9

    Last publish

    Collaborators

    • royston