Nodular Pudding Multiverse

    quickblox-ie-support

    0.0.1 • Public • Published

    QuickBlox JavaScript SDK

    travis-ci Code Climate npm npm

    The QuickBlox JavaScript SDK provides a JavaScript library making it even easier to access the QuickBlox cloud communication backend platform.

    QuickBlox is a suite of communication features & data services (APIs, SDKs, code samples, admin panel, tutorials) which help digital agencies, mobile developers and publishers to add great communication functionality to smartphone applications like in Skype, WhatsApp, Viber.

    Check out our API Reference for more detailed information about our SDK.

    Install

    Dependencies for browser

    <script src="https://cdnjs.cloudflare.com/ajax/libs/quickblox/2.12.4/quickblox.min.js"></script>

    Bower and RequireJS

    If you use the bower package manager for your project, you can install the JS SDK through bower:

    bower install quickblox --save
    

    When you use RequireJS, you are able to use QuickBlox as an AMD compliant module. The SDK supports the UMD (Universal Module Definition) pattern for JavaScript modules, so it is possible to use the SDK everywhere (as a global variable in the browser via an AMD module loader like RequireJS or as a CommonJS module in a Node.js environment).

    Node.js and NPM integration

    Also you can use QuickBlox JavaScript SDK with server-side applications on NodeJS through the native node package. Just install the package in your application project like this:

    npm install quickblox --save
    

    And you're ready to go:

    var QB = require('quickblox');
    
    // OR to create many QB instances
    var QuickBlox = require('quickblox').QuickBlox;
    var QB1 = new QuickBlox();
    var QB2 = new QuickBlox();

    Download ZIP archive

    QuickBlox JavaScript SDK, zip archive

    Browsers support

    Edge Firefox Chrome Safari Opera Node.js
    14+ 52+ 50+ 11.1+ 36+ 6+

    Documentation

    You can look at it here https://quickblox.com/developers/Javascript

    Known issues

    • We are recommend you to use BOSH chat protocol instead of WebSockets for EI/Edge browsers.

    Questions and feedback

    Please raise questions, requests for help etc. via https://stackoverflow.com/questions/tagged/quickblox

    Feedback and suggestions for improvement always welcome :)

    How to contribute

    See more information at contributing.md

    License

    Apache 2.0

    Install

    npm i quickblox-ie-support

    DownloadsWeekly Downloads

    0

    Version

    0.0.1

    License

    (Apache-2.0)

    Unpacked Size

    2.85 MB

    Total Files

    48

    Last publish

    Collaborators

    • bhadri1255