pwd-check

1.1.5 • Public • Published

pwd-check

Build Status Coverage Status Known Vulnerabilities code style: prettier

NPM

A simple CLI tool to check if a password has been pwned using https://haveibeenpwned.com API.


Getting Started

Install the npm package globally:

npm install -g pwd-check

Run the tool:

pwd-check

Prerequisites

It's recommended to use Node.js version >= 14.0.0 to run this package.

Installing

Clone the GitHub repository:

git clone git@github.com:ClaudioCorridore/pwd-check.git

Navigate to the cloned project folder:

cd pwd-check

Install the npm dependencies:

npm install

Build the project:

npm run build

Running the tests

To run the tests:

npm test

Contributing

Please read CONTRIBUTING.md for details on our code of conduct, and the process for submitting pull requests to us.

Versioning

We use SemVer for versioning. For the versions available, see the tags on this repository.

Authors

License

This project is licensed under the MIT License - see the LICENSE.md file for details.

Acknowledgments

Package Sidebar

Install

npm i pwd-check

Weekly Downloads

1

Version

1.1.5

License

ISC

Unpacked Size

847 kB

Total Files

5

Last publish

Collaborators

  • cclaudio