psuauth

0.0.4 • Public • Published

psuauth

JavaScript authentication module for Penn State (LDAP)

Environment:

node version: 0.12.7 npm version: 2.11.3

Please refer to 'package.json' for packages versions.

Install

npm install psuauth

(Please ignore the error messages during installation. It should be caused by ldapjs package.)

Example

var psuauth = require('psuauth');
var Q = require('q');
psuauth('', '') // first argument is username, secone argument is password
.then(function(info) {
  console.log(info);
})
.fail(function(err) {
  console.log(err);
});

Package Sidebar

Install

npm i psuauth

Weekly Downloads

1

Version

0.0.4

License

MIT

Last publish

Collaborators

  • wuyu