Nasal Piercings Manipulator

    praat

    6.0.9 • Public • Published

    node-praat

    A cross-platform NPM installer for Praat, for use in node.js programs. This package is aimed at developers/users of Praat scripts wishing to integrate them easily with Node.

    How to install

    npm install praat

    Usage

    var praat = require('praat');
    var spawn = require('child_process').spawn;
     
    spawn(praat, ['my_script.praat'], /* etc */);

    System notes

    On Windows and Linux, the installer will grab the appropriate Praat binary from the Praat website. Both 32-bit and 64-bit OSs are supported. Other OSs are currently not supported.

    The installer does not ensure that Praat's own dependencies are installed (on Linux these are GTK, asound and libc >= 2.11 as the Praat website notes here).

    On Windows, you get Praatcon (the console variant) rather than Praat (the GUI application).

    Keywords

    Install

    npm i praat

    DownloadsWeekly Downloads

    6

    Version

    6.0.9

    License

    MIT

    Last publish

    Collaborators

    • motiz88