Neutralize Pesky Miscreants

    pouchdb-triplesec

    0.0.2 • Public • Published

    PouchDB Triplesec

    Plugin to encrypt a PouchDB/CouchDB database.

    Installation

    Node.js

    npm install pouchdb-triplesec
    var pouchdb = require('pouchdb');
    pouchdb.plugin(require('pouchdb-triplesec'));

    Browser

    <script src="pouchdb.js"></script>
    <script src="pouchdb.pouchdb-triplesec.js"></script>

    API

    var db = new PouchDB('my_database');
     
    db.enableCrypto(password);
     
    // Docs are transparently encrypted/decrypted.

    Install

    npm i pouchdb-triplesec

    DownloadsWeekly Downloads

    2

    Version

    0.0.2

    License

    MIT

    Last publish

    Collaborators

    • vortexchat