Nomenclature Predictably Misunderstood

    postcss-merge-grid-template

    0.8.1 • Public • Published

    PostCSS Merge Grid Template Build Status

    PostCSS plugin to reduce grid templates declarations.

    #page {
        display: grid;
        width: 100%;
        height: 250px;
        grid-template-areas: "head head"
                             "nav  main"
                             "nav  foot";
        grid-template-rows: 50px 1fr 30px;
        grid-template-columns: 150px 1fr;
    }
    #page {
        display: grid;
        width: 100%;
        height: 250px;
        grid-template: "a a" 50px "b c" 1fr "b d" 30px / 150px 1fr;
    }

    Status: EXPERIMENTAL ☢️

    ☠ ☠ ☠ ☠ ☠ ☠ ☠

    This plugin is still under development and does not currently cover all the possible places where zone identifiers can hide. That means it is likely to break your code by renaming half of the identifiers. Use it only if you know what you are doing.

    Usage

    postcss([ require('postcss-merge-grid-template') ])

    See PostCSS docs for examples for your environment.

    Install

    npm i postcss-merge-grid-template

    DownloadsWeekly Downloads

    45

    Version

    0.8.1

    License

    MIT

    Unpacked Size

    9.31 kB

    Total Files

    11

    Last publish

    Collaborators

    • sylvainpolletvillard