Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

pos-portal-operational-reports-ui

1.1.2 • Public • Published

Background

UI Project for Point of Sale (POS) Portal Operational Reports

Technical

This project is written in typescript, using gulp and tsify as the build system. To build this project run:

Building the Project

npm install
npm run build

Watching for changes

Gulp can watch for changes and rebuild whenever your source files change. To start watching for changes run

npm run watch

Known issues

Yarn: source-map requires node@>=8

When using yarn (instead of npm) you may see this error. It seems npm just ignores this problem, but the source-map npm package does indeed require NodeJS v8 or higher. Since portal is currently stuck on NodeJS v6.x, this could pose an issue. However, source-maps are not required for production, so this shouldn't be a big problem. To avoid this problem, you have two options;

  1. Pass the --ignore-engines flag with your yarn commands
  2. Use npm instead of yarn

Keywords

none

Install

npm i pos-portal-operational-reports-ui

DownloadsWeekly Downloads

1

Version

1.1.2

License

ISC

Unpacked Size

78.3 kB

Total Files

28

Last publish

Collaborators

  • avatar