New Prague, Minnesota

    please-use-yarn

    1.2.1 • Public • Published

    please-use-yarn

    强制在项目中使用 yarn 作为包管理器

    使用

    package.json 文件的 scripts 中添加 preinstall

    {
      "scripts": {
        "preinstall": "npx please-use-yarn"
      }
    }

    效果

    当使用 npm i 安装依赖时,会报错并停止安装。

    备注: 如果不想看到 npx: 1 安装成功,用时 xxxx 秒,可以使用 --quiet 选项(或者 -q):

    {
      "scripts": {
        "preinstall": "npx -q please-use-yarn"
      }
    }

    License

    MIT

    Keywords

    Install

    npm i please-use-yarn

    DownloadsWeekly Downloads

    14

    Version

    1.2.1

    License

    MIT

    Unpacked Size

    2.45 kB

    Total Files

    4

    Last publish

    Collaborators

    • iamjjc