platypus

A front-end MVVM framework written in TypeScript

PlatypusTS Distribution

This repo is for distribution of PlatypusTS through bower and npm.

You can use either npm or bower to install this package.

npm install platypus --save

This package works in CommonJS and on window, so if you are using Browserify or other CommonJS module loaders you can use require('platypus'). If you want to use plat on window, you need to include it in your index.html:

<script src="/node_modules/platypus/dist/platypus.min.js"></script>
bower install platypus --save

This package works with CommonJS and on window. We recommend using Browserify with debowerify, which gives you the ability to use require('platypus') with bower components. If you want to use plat on window, you need to include it in your index.html:

<script src="/bower_components/platypus/dist/platypus.min.js"></script>

This package includes a declaration file, as well as the source .js and .min.js file. If you are using TypeScript, you will want to reference the declaration file. The recommended way is through TSD.

tsd link
/// <reference path="/typings/tsd.d.ts" />
/// <reference path="/node_modules/platypus/dist/platypus.d.ts" />
/// <reference path="/bower_components/platypus/dist/platypus.d.ts" />

It is recommended that you use a CommonJS module loader with PlatypusTS in favor of using window.plat.

Documentation is available on the Platypi website.