pino-logflare
TypeScript icon, indicating that this package has built-in type declarations

0.4.2 • Public • Published

pino-logflare

This module provides transport for pino that forwards messages to your Logflare account.

You can use pino-logflare both for node and browser apps. We also support isomorphic Vercel apps.

Installation

To use globally from command line:

$ npm install -g pino-logflare

To include as a library in your project:

$ npm install pino-logflare

CLI

Want to use pino-logflare from the CLI? See the CLI documentation for details.

API

Want to use pino-logflare as a library in your project? See the API documentation for details.

Vercel

Set up pino-logflare to use in your Vercel project. See the VERCEL documentation for details.

Known Issues

  • Not compatible with pino-pretty.

Credits

Thanks to @zackkrida for creating the initial version of pino-logflare.

Thanks to @ovhemert for creating the pino-datadog project this transport is based on.

Contributing

If you would like to help out with some code, check the details.

License

Licensed under MIT.

Package Sidebar

Install

npm i pino-logflare

Weekly Downloads

4,216

Version

0.4.2

License

MIT

Unpacked Size

32.8 kB

Total Files

23

Last publish

Collaborators

  • ziinc_supabase
  • chasers