pg3d-autocorrect

1.1.6 • Public • Published

Usage

Default options

var pg3dautocorrect = require('pg3dautocorrect')()
autocorrect('extermator') // exterminator

Custom dictionary path

var path = '/usr/share/dict/words'
var pg3dautocorrect = require('pg3dautocorrect')({dictionary: path})
autocorrect('extermator') // exterminator

Custom words

var words = ['pixelgun', 'antichampionrifle', 'laserbow']
var pg3dautocorrect = require('pg3dautocorrect')({words: words})
autocorrect('larbow') // laserbow

Options

  • words - a list of words to use for matching
  • dictionary - path to dictionary file

Package Sidebar

Install

npm i pg3d-autocorrect

Weekly Downloads

6

Version

1.1.6

License

ISC

Unpacked Size

8.02 kB

Total Files

15

Last publish

Collaborators

  • jeffplays2005