Nonconformist Propaganda Machine
Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

paul-revere-nats-adapter

1.0.0 • Public • Published

NATS Adapter for Paul Revere

Usage

Pass a connected NATS client, then pass the adapter to Paul Revere. NATS client must be configured to use JSON.

const PaulRevere = require('paul-revere'),
    PRNats = require('paul-revere-nats-adapter'),
    nats = require('nats');
 
const natsClient = nats.connect({json: true});
 
const paul = new PaulRevere(<your-schemas>, <your-server>, new PRNats(natsClient));

install

npm i paul-revere-nats-adapter

Downloadsweekly downloads

1

version

1.0.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability