package-dependencies

    1.0.1 • Public • Published

    package-dependencies Build Status npm version

    Get package.json dependencies from a Github repository

    Install

    npm install --save package-dependencies
    

    Usage

    const packageDependencies = require('package-dependencies');
     
    packageDependencies.getAll('ecrmnn', 'spaceholder', '1.3.1', function (all) {
      console.log(all);
      //=> {dependencies: ['commander', 'random-string'], devDependencies: ['chai', 'mocha']}
    });
    const packageDependencies = require('package-dependencies');
     
    packageDependencies.getDependencies('ecrmnn', 'spaceholder', '1.3.1', function (deps) {
      console.log(deps);
      //=> ['commander', 'random-string']
    });
    const packageDependencies = require('package-dependencies');
     
    packageDependencies.getDevDependencies('ecrmnn', 'spaceholder', '1.3.1', function (devDeps) {
      console.log(devDeps);
      //=> ['chai', 'mocha']
    });

    License

    MIT © Daniel Eckermann

    Install

    npm i package-dependencies

    DownloadsWeekly Downloads

    1

    Version

    1.0.1

    License

    MIT

    Last publish

    Collaborators

    • ecrmnn