obvious-closure-library

Fork of closure-library that allows installation via NPM.

Closure Library

This is Medium's fork of the Google Closure Library.

We try to keep it reasonably up to date, but only after testing that it is compatible with our products. There may occasionally be changes introduced to work around temporary issues or to try out fixes in preparation of upstream patches.

The package number reflects the date that we last merged the fork. We rebase our changes on top of origin/master, so that our modifications are always on top of the closure-library master changes.

require('obvious-closure-library').bootstrap()
goog.require('goog.string.linkify')
goog.string.linkify.linkifyPlainText('Hello www.world.com')

The repository contains a lot of test files and demos, as such we include a postinstall script that removes these files from the node_modules directory when installed via NPM.

This project isn't intended for external contribution, we suggest instead you send patches directly.

Closure Library is a powerful, low-level JavaScript library designed for building complex and scalable web applications. It is used by many Google web applications, such as Google Search, Gmail, Google Docs, Google+, Google Maps, and others.

For more information, visit the Google Developers or GitHub sites.

Developers, please see the Generated API Documentation.

See also the goog.ui Demos