nodesu
    TypeScript icon, indicating that this package has built-in type declarations

    0.7.3 • Public • Published

    nodesu!

    a node.js osu! api wrapper.

    NPM

    Installing

    node.js >=4.0.0 must be used for this library to work!

    $ npm install nodesu
    
    # or install from GitHub
    $ npm install nicholastay/nodesu
    

    note!: nodesu has been rewritten from the ground up since v0.6.0. All sections of programs which utilize this library probably have to be rewritten if migrating from previous versions!

    Getting Started

    const Nodesu = require('nodesu');
    
    const api = new Nodesu.Client('_api-key-here_');
    // ... see docs/Modules:Components - typical usage = api.<component>.<function>();
    // most functions return Promise objects.
    
    // eg: get beatmap data
    api.beatmaps
        .getByBeatmapId('646609')
        .then(console.log); // outputs to stdout.

    Links

    Documentation note

    Most of what you want to find should be under the "Client" class, or the Modules section (categorized classes).

    Contributing

    Contributions are much welcome via issues or pull requests.

    License

    Zlib/libpng license. Full text in the root of this repository.

    Install

    npm i nodesu

    DownloadsWeekly Downloads

    81

    Version

    0.7.3

    License

    Zlib

    Unpacked Size

    1.46 MB

    Total Files

    130

    Last publish

    Collaborators

    • nicholastay