Nascent Political Miscreant

    node-redis-store

    0.10.0 • Public • Published

    npm version Build Status Coverage Status Dependency Status Gratipay donate button

    node-redis-store See on Github

    Simplistic node redis store ready can scale with generic-pool support

    Prerequisites

    node >= 4 This module requires nodejs v4 or above as it has dependencies on es6 components such as Map, Set, Promise etc.

    Getting started

        npm install node-redis-store
    

    Usage

        const RedisStore = require("node-redis-store");
        const store = new RedisStore();
    
        // set
        store.set("key", {a: "b"});
    

    API

    • RedisStore([options])

    options object properties

    Name Type Description
    name string

    Name your store

    redisOptions object

    opts from node_redis#options-object-properties

    poolOptions object

    opts from node-pool#createpool

    logger object

    Inject your custom logger

    Run tests

    bash test.sh
    

    Contribute

    Discover how you can contribute by heading on over to the CONTRIBUTING.md file.

    Backers

    Maintainers

    These amazing people are maintaining this project:

    Sponsors

    No sponsors yet! Will you be the first?

    Patreon donate button Gratipay donate button Flattr donate button

    Click here to lend your support to: simple-node-redis-cache and make a donation at pledgie.com !

    Contributors

    These amazing people have contributed code to this project:

    Discover how you can contribute by heading on over to the CONTRIBUTING.md file.


    ---

    Install

    npm i node-redis-store

    DownloadsWeekly Downloads

    1

    Version

    0.10.0

    License

    WTFPL

    Last publish

    Collaborators

    • pasupulaphani