micromark-util-combine-extensions
TypeScript icon, indicating that this package has built-in type declarations

2.0.0 • Public • Published

micromark-util-combine-extensions

Build Coverage Downloads Size Sponsors Backers Chat

micromark utility to combine syntax or html extensions.

Contents

What is this?

This package can merge multiple extensions into one.

When should I use this?

This package might be useful when you are making “presets”, such as micromark-extension-gfm.

Install

This package is ESM only. In Node.js (version 16+), install with npm:

npm install micromark-util-combine-extensions

In Deno with esm.sh:

import {combineExtensions} from 'https://esm.sh/micromark-util-combine-extensions@1'

In browsers with esm.sh:

<script type="module">
  import {combineExtensions} from 'https://esm.sh/micromark-util-combine-extensions@1?bundle'
</script>

Use

import {gfmAutolinkLiteral} from 'micromark-extension-gfm-autolink-literal'
import {gfmStrikethrough} from 'micromark-extension-gfm-strikethrough'
import {gfmTable} from 'micromark-extension-gfm-table'
import {gfmTaskListItem} from 'micromark-extension-gfm-task-list-item'
import {combineExtensions} from 'micromark-util-combine-extensions'

const gfm = combineExtensions([gfmAutolinkLiteral, gfmStrikethrough(), gfmTable, gfmTaskListItem])

API

This module exports the identifiers combineExtensions and combineHtmlExtensions. There is no default export.

combineExtensions(extensions)

Combine multiple syntax extensions into one.

Parameters
  • extensions (Array<Extension>) — list of syntax extensions
Returns

A single combined extension (Extension).

combineHtmlExtensions(htmlExtensions)

Combine multiple html extensions into one.

Parameters
  • htmlExtensions (Array<HtmlExtension>) — list of HTML extensions
Returns

A single combined HTML extension (HtmlExtension).

Types

This package is fully typed with TypeScript. It exports no additional types.

Compatibility

Projects maintained by the unified collective are compatible with maintained versions of Node.js.

When we cut a new major release, we drop support for unmaintained versions of Node. This means we try to keep the current release line, micromark-util-combine-extensions@^2, compatible with Node.js 16. This package works with micromark@^3.

Security

This package is safe. See security.md in micromark/.github for how to submit a security report.

Contribute

See contributing.md in micromark/.github for ways to get started. See support.md for ways to get help.

This project has a code of conduct. By interacting with this repository, organisation, or community you agree to abide by its terms.

License

MIT © Titus Wormer

Package Sidebar

Install

npm i micromark-util-combine-extensions

Weekly Downloads

3,945,722

Version

2.0.0

License

MIT

Unpacked Size

11 kB

Total Files

4

Last publish

Collaborators

  • wooorm