Never Patronize Mothers

    This package has been deprecated

    Author message:

    bad

    memecord

    3.0.1 • Public • Published

    memecord

    Join the support discord NPM Version Downloads Dependencies Greenkeeper badge Codacy Badge

    NPM

    About


    memecord is a Discord bot framework, based on discord.js, that allows you to easily create Discord bots. Take a look at the Documentation for further info.

    Installation


    NodeJS 6.0.0 or newer is required
    Ignore any warnings about unmet peer dependencies, as they're all optional.

    Without voice support: npm install memecord --save
    With voice support: npm install memecord node-opus --save

    Example


    const memecord = require('memecord');
     
    const client = new memecord.Client({
        token: 'your token here',
        ownerID: '277411860125581312',
        prefix: 'meme!',
        logLevel: 'VERBOSE'
    });
     
    const someCommand = new memecord.Command({
      names: ['meme', 'memes'],
      description: 'Sends a random meme',
      cooldown: 1000,
      run: function(message) {
        message.channel.send('Error 404: Meme not found');
      }
    });
     
    client.registerCommand(someCommand);
     
    client.run();

    Links


    Help


    If you don't understand something in the documentation, how to use the framework, you are experiencing problems, or you just need friends (i feel you), don't hesistate to join our Discord Server

    Install

    npm i memecord

    DownloadsWeekly Downloads

    12

    Version

    3.0.1

    License

    Apache-2.0

    Last publish

    Collaborators

    • matmen