Norvell, Please Merge

    mdast-util-phrasing
    TypeScript icon, indicating that this package has built-in type declarations

    3.0.1 • Public • Published

    mdast-util-phrasing

    Build Coverage Downloads Size Sponsors Backers Chat

    mdast utility to check if a node is phrasing content.

    Contents

    What is this?

    This package is a tiny utility to check that a given node is phrasing content.

    When should I use this?

    This utility is typically useful if you’re making other utilities. It uses unist-util-is, which you can use for your own checks.

    A different utility, hast-util-phrasing, does the same but on hast.

    Install

    This package is ESM only. In Node.js (version 14.14+ and 16.0+), install with npm:

    npm install mdast-util-phrasing

    In Deno with esm.sh:

    import {phrasing} from 'https://esm.sh/mdast-util-phrasing@3'

    In browsers with esm.sh:

    <script type="module">
      import {phrasing} from 'https://esm.sh/mdast-util-phrasing@3?bundle'
    </script>

    Use

    import {phrasing} from 'mdast-util-phrasing'
    
    phrasing({type: 'paragraph', children: [{type: 'text', value: 'Alpha'}]})
    // => false
    
    phrasing({type: 'strong', children: [{type: 'text', value: 'Delta'}]})
    // => true

    API

    This package exports the identifier phrasing. There is no default export.

    phrasing(value)

    Check if the given value is phrasing content.

    Parameters
    • value (unknown) — thing to check, typically Node
    Returns

    Whether value is phrasing content (boolean).

    Types

    This package is fully typed with TypeScript. It does not export extra types.

    Compatibility

    Projects maintained by the unified collective are compatible with all maintained versions of Node.js. As of now, that is Node.js 14.14+ and 16.0+. Our projects sometimes work with older versions, but this is not guaranteed.

    Security

    Use of mdast-util-phrasing does not involve hast, user content, or change the tree, so there are no openings for cross-site scripting (XSS) attacks.

    Related

    Contribute

    See contributing.md in syntax-tree/.github for ways to get started. See support.md for ways to get help.

    This project has a code of conduct. By interacting with this repository, organization, or community you agree to abide by its terms.

    License

    MIT © Victor Felder

    Install

    npm i mdast-util-phrasing

    DownloadsWeekly Downloads

    428,008

    Version

    3.0.1

    License

    MIT

    Unpacked Size

    9.33 kB

    Total Files

    7

    Last publish

    Collaborators

    • wooorm
    • kmck