maxlength-contenteditable

1.0.1 • Public • Published

Max length plugin for contenteditable HTML attribute

Simple maxlength plugin validator for contenteditable html attribute, this plugin do not allow you to put more than the specified max length, paste from clipboard is also checked.

Demo Link

Demo here

Installation

npm

$ npm install maxlength-contenteditable --save

yarn

$ yarn add maxlength-contenteditable --save

unpkg CDN

You can also skip yarn/npm install by using repos on the cdn

<script src="https://unpkg.com/maxlength-contenteditable@1.0.1/dist/maxlength-contenteditable.js"></script>

initialize

you have 3 ways to do it :

CommonJS

var maxlengthContentEditableLib = require('maxlength-contenteditable');

ES6 import

import {maxlengthContentEditable} from 'maxlength-contenteditable';

Global variable (only if you added the script via CDN in your index.html file)

maxlengthContentEditableModule.maxlengthContentEditable();

### Example of use

<div contenteditable="true" data-max-length="10"></div>

Compatibility

IE 9+ , Chrome , Firefox , Opera

Package Sidebar

Install

npm i maxlength-contenteditable

Weekly Downloads

578

Version

1.0.1

License

MIT

Unpacked Size

35.9 kB

Total Files

4

Last publish

Collaborators

  • stephen31