markdown-it-mark

4.0.0 • Public • Published

markdown-it-mark

CI NPM version Coverage Status

<mark> tag plugin for markdown-it markdown parser.

v3.+ requires markdown-it v10.+, see changelog.

==marked== => <mark>inserted</mark>

Markup uses the same conditions as CommonMark emphasis.

Install

node.js, browser:

npm install markdown-it-mark --save
bower install markdown-it-mark --save

Use

var md = require('markdown-it')()
            .use(require('markdown-it-mark'));

md.render('==marked==') // => '<p><mark>marked</mark></p>'

Differences in browser. If you load script directly into the page, without package system, module will add itself globally as window.markdownitMark.

License

MIT

Package Sidebar

Install

npm i markdown-it-mark

Weekly Downloads

167,951

Version

4.0.0

License

MIT

Unpacked Size

15.7 kB

Total Files

7

Last publish

Collaborators

  • vitaly