markdown-it-ins

4.0.0 • Public • Published

markdown-it-ins

CI NPM version Coverage Status

<ins> tag plugin for markdown-it markdown parser.

v3.+ requires markdown-it v10.+, see changelog.

++inserted++ => <ins>inserted</ins>

Markup uses the same conditions as CommonMark emphasis.

Install

node.js, browser:

npm install markdown-it-ins --save
bower install markdown-it-ins --save

Use

var md = require('markdown-it')()
            .use(require('markdown-it-ins'));

md.render('++inserted++') // => '<p><ins>inserted</ins></p>'

Differences in browser. If you load script directly into the page, without package system, module will add itself globally as window.markdownitIns.

License

MIT

Package Sidebar

Install

npm i markdown-it-ins

Weekly Downloads

152,083

Version

4.0.0

License

MIT

Unpacked Size

15.6 kB

Total Files

7

Last publish

Collaborators

  • vitaly