magic-script-components-lumin
    TypeScript icon, indicating that this package has built-in type declarations

    2.0.0 • Public • Published

    MagicScript Components Lumin

    CI npm version License

    MagicScript Component Framework for Lumin Runtime platform

    This package is meant to be used along with MagicScript Components and both should be included as dependencies in the project's package.json.

    Installation

    1. Install magic-script-cli:
    npm install -g magic-script-cli
    1. Create new MagicScript application:
    magic-script init
    • Follow the steps.
    • Choose "Components" when application type is requested.
    1. Install the required npm packages from the app folder:
    npm install
    1. Build and install your application:
    magic-script build
    1. Refer to MagicScript Getting Started guide for more information.

    Update Existing Project

    To update your existing MagicScript Components project run the following commands:

    yarn add magic-script-components-lumin
    yarn add magic-script-components@2.0.0

    or with npm

    npm install --save magic-script-components-lumin
    npm install --save magic-script-components@2.0.0

    This will update you existing MagicScript Components project to use the latest version of the library.

    Usage

    See Components Documentation

    License

    This project is licensed under the Apache License, Version 2.0 - see the LICENSE file for details

    Keywords

    Install

    npm i magic-script-components-lumin

    DownloadsWeekly Downloads

    0

    Version

    2.0.0

    License

    Apache-2.0

    Unpacked Size

    1.09 MB

    Total Files

    176

    Last publish

    Collaborators

    • avatar