New Pretend Meaning

    macos-accessibility-permissions
    TypeScript icon, indicating that this package has built-in type declarations

    1.0.1 • Public • Published

    macos-accessibility-permissions

    Check and request macOS accessibility permissions.

    Requires macOS 10.12 or later. macOS 10.13 or earlier needs to download the Swift runtime support libraries.

    Install

    $ npm install macos-accessibility-permissions
    

    Usage

    const hasPermissions = require('macos-accessibility-permissions');
     
    hasPermissions()
     
    // false
     
    hasPermissions({ask: true})
     
    // false
     
    // After enabling permissions
     
    hasPermissions()
     
    // true

    API

    hasPermissions({hasAsked: boolean}): boolean

    Returns true if the permissions are granted, and false otherwise. Optionally provide a hasAsked parameter to trigger the accessibility dialog

    Related

    • mac-focus-window - Focus a window and bring it to the front on macOS
    • mac-windows - Provide Information about Application Windows running

    License

    MIT

    Install

    npm i macos-accessibility-permissions

    DownloadsWeekly Downloads

    78

    Version

    1.0.1

    License

    MIT

    Unpacked Size

    20.6 kB

    Total Files

    5

    Last publish

    Collaborators

    • gkaragkiaouris