node package manager

lyria-template

Lyria Project Template

Build Status Dependency Status devDependency Status

Dependencies

  • Handlebars Runtime (default templating engine of Lyria)
  • Require.JS or any other AMD loader (Lyria uses with Almond.JS by default)
  • Modernizr (Optional, but included by default)
  • Detectr

Features

  • Preparing assets (scenes and prefabs)
  • Source map support for assets and JavaScript files

Developer dependencies

  • Grunt
  • Handlebars
  • Stylus (Lyria bundles Stylus, but any other CSS preprocessor can be used as well)

Getting started

Prerequisites:
Node.js 0.10 or higher needs to be installed

Go ahead and download the latest template version.
Navigate into the folder where extracted the template and run npm install.

Using the lyria template:

  • grunt: Same as grunt development
  • grunt development: Builds the current project
  • grunt production: Builds the current project, minifies everything and places it in the builds folder
  • grunt deploy: Does a production builds and makes a package out of it

Bitdeli Badge