lokijs-plugin

    2.0.2 • Public • Published

    About lokijs-plugin

    A hapi plugin to facilitate the initialization of lokijs within your application. Version 2.0.0 of this plugin has been updated and tested specifically for working with version 17 and 18 of Hapi.

    Build Status

    See the example directory for details on accessing the database within routes.

    Usage

    'use strict';
     
    const Hapi = require('@hapi/hapi');
     
    const server = new Hapi.Server({
        host: 'localhost',
        port: 3000
    });
     
    const startup = async () => {
        await server.register([{
            plugin: require('lokijs-plugin'),
            options: {
                env: 'NODEJS' 
            }
        }]);
        await server.start();
    };
     
    startup().catch((err) => {
        throw err;
    });
     
    console.log(`${new Date()}: server running at ${server.info.uri}`);

    Install

    npm i lokijs-plugin

    DownloadsWeekly Downloads

    0

    Version

    2.0.2

    License

    BSD-3-Clause

    Unpacked Size

    11.2 kB

    Total Files

    9

    Last publish

    Collaborators

    • visualjeff