Miss any of our Open RFC calls?Watch the recordings here! »

linter-flow

0.1.4 • Public • Published

linter-flow package

linter-flow implements a linter plugin for Facebook's Flow JS typechecker.

How to use it

  1. Install Flow
  2. Install the package
  3. Create an empty .flowconfig file at the root of your repo
  4. Open a JS file

You should start seeing lint errors related to types - try opening the Flow example projects in Atom

Troubleshooting

OS X: No lint errors are shown?
  • Possible cause: The PATH to your Flow executable cannot be found.
  • Solution: Try launching Atom from the terminal. Alternative workarounds here: atom/atom-shell#550

Keywords

none

Install

npm i linter-flow

DownloadsWeekly Downloads

1

Version

0.1.4

License

MIT

Last publish

Collaborators

  • avatar