Nervously Practice Multithreading

    lint-coffee-strict

    1.2.1 • Public • Published

    lint-coffee-strict@1.2.1

    npm version build status dependency status devDependency status

    coffeelint preconfigured with WappForge style guide

    Usage

    LintRunner = require 'lint-coffee-strict'
     
    LintRunner.run ["src/**/*.coffee""examples/**/*.coffee"]
    # Lint all files in src/ and examples/ and show debug information on lint-coffee-strict 
    DEBUG=lint-coffee-strict lint-coffee-strict src/**/*.coffee examples/**/*.coffee

    Installation

    Download node at nodejs.org and install it, if you haven't already.

    npm install lint-coffee-strict --save

    This package is provided in these module formats:

    • CommonJS

    Dependencies

    Dev Dependencies

    • create-readme: Automatically creates README.md based on package.json and other existing files.
    • ghooks: Simple git hooks
    • nsp: The Node Security (nodesecurity.io) command line interface
    • semantic-release: automated semver compliant package publishing
    • validate-commit-message: GIT COMMIT-MSG hook for validating commit message.

    License

    MIT

    Install

    npm i lint-coffee-strict

    DownloadsWeekly Downloads

    1

    Version

    1.2.1

    License

    MIT

    Last publish

    Collaborators

    • dbartholomae