Nupital Pomp Mesmerises

    lasso-coffee

    1.0.7 • Public • Published

    lasso-coffee

    Lasso.js plugin to support compilation of CoffeeScript dependencies.

    Installation

    npm install lasso-coffee --save

    The lasso-coffee plugin will then need to be registered as shown below before you can start adding CoffeeScript dependencies:

    require('lasso').configure({
        ...
        plugins: [
            'lasso-coffee',
            ...
        ]
    });

    Basic Usage

    browser.json

    {
        "dependencies": [
            "./foo.coffee",
            "./bar.coffee"
        ]
    }

    The lasso-coffee plugin will concatenate all of the CoffeeScript dependencies targeted for the same bundle and pass that as input to the CoffeeScript renderer. Therefore, given the following contents of each file:

    foo.coffee:

    foo = 'foo'

    bar.coffee:

    bar = 'bar'

    The output will be the following:

    var foo = 'foo';
     
    var bar = 'bar';

    Install

    npm i lasso-coffee

    DownloadsWeekly Downloads

    2

    Version

    1.0.7

    License

    Apache License v2.0

    Last publish

    Collaborators

    • scttdavs