Have ideas to improve npm?Join in the discussion! »

koa-face-errors

1.0.2 • Public • Published

koa-face-errors

Errors with ASCII faces. Just because.

Based on cool-ascii-faces

Installation

npm install --save koa-face-errors

Usage

Require in your middleware stack somewhere near the top, it'll catch your Error and slip some fun in the mix.

Example

var app = require('koa'),
    faceHandler = require('koa-face-errors'),
    port = process.env.PORT || 3000
 
app.use(faceHandler())
 
app.use(function *(){
  this.throw(500, 'whoops')
})
 
app.listen(port)
console.log('Listening on port', port)
 

Install

npm i koa-face-errors

DownloadsWeekly Downloads

2

Version

1.0.2

License

MIT

Last publish

Collaborators

  • avatar