Ninja Parading Musically

    karma-should

    1.0.0 • Public • Published

    karma-should

    Use should.js (2.0.2+) with karma tests.

    Status

    npm version

    Installation

    Install the package via npm:

    $ npm install karma-should --save

    Usage

    Add should as part of frameworks property configuration of karma. In the following example, the testing framework mocha is also included although not required.

    module.exports = function(config) {
      config.set({
        frameworks: ['mocha', 'should']
      });
    };

    By default, karma loads all plugins that are siblings to it and their name matches karma-* so no additional configuration is required.

    Load karma and all should assertions will now available in the tests:

    describe('karma tests with should', function() {
      var user = {
        name: 'foo'
      };
     
      it('should have a name', function() {
        user.should.have.property('name', 'foo');
      });
    });

    License

    MIT

    Install

    npm i karma-should

    DownloadsWeekly Downloads

    312

    Version

    1.0.0

    License

    MIT

    Last publish

    Collaborators

    • ruimarinho